Полная версия: Solved FATFS: Error 5 in mounting a logical drive 0
Вы просматриваете yпpощеннyю веpсию форума. Пеpейти к полной веpсии.
Hey guys,

I've just tried to upgrade my Dreamcast IDE hard drive from a 160GB Samsung drive to a 250GB WD drive. I am now getting an error at start up reading: FATFS: Error 5 in mounting a logical drive 0. The 160GB drive continues to work. My IDE to Sata convertor still works on it also. Is there a known fault with WD drives or anything like that.

Thank you for your help.
Maybe this is just bad formatting. Looks like a wrong partition type or MBR in general.
Your HDD seems to detected, but reading of data is failed or readed something that not waiting Smile
First of all I want to thank you SWAT for replying so many months ago but the problem wasn't formatting but all my own fault.

The problem was caused because the HDD activity LED was wired incorrectly. So for future if anyone else has the same issue where some hard drives work but others do not, pin 39 which isn't actually used for data could be the cause.
URL ссылки